This page provides real-time updates on the status of all Topstep systems and services. If something is listed below, the team is aware and working to restore service as quickly as possible.
Overview Yesterday an issue was detected with our payment processing partner. Some Mastercard purchases made since June 22, 2026 were delayed on their end and *Topstep was not notified*.
Since payments were not fully processed, our processing partner processed them again this weekend. *Topstep was also not notified of this weekend’s processing.*
Depending on your bank and based on information provided to us by our processing partner, you may see one or both of these scenarios: - Removed or reversed charges - A new charge for the same purchase
What To Expect - Once your bank finishes processing, you should see one completed charge for each purchase, and your final balance should match what you originally agreed to pay. **Our processing partner has confirmed you should not be charged twice.**
- Some affected payments have not been reprocessed yet. Our processing partner expects to retry those transactions in the coming days. **If your account is affected, Topstep will notify you before any additional payment attempt is made so you know what to expect.**
What You Need To Do For now, please allow your bank time to finish processing transactions. Should you run into further issues, please contact Trader Support with: - The details of the purchase - Screenshots showing both charges
We know seeing unexpected charges on your card can be unsettling, and we appreciate your patience while we worked with our payment partner to identify and resolve the issue.
Overview We have identified the cause of the recent payment notifications. While initial reports were heavily concentrated among traders using Revolut, we want to clarify that Revolut was not the root cause of this incident.
Revolut was simply one of the primary card issuers impacted. The full scope of this issue extends to Mastercard purchases made across all credit card issuers over the last 5 weeks.
What Happened Over the last 5 weeks, a number of authorized Mastercard transactions were not properly settled behind the scenes by our payment processing partners and ultimately failed. To collect these outstanding balances, our payment partners retried these failed settlement attempts in bulk this morning.
Because Revolut's app provides immediate real-time notifications for captures and cancellations, the impact was most visible to Revolut cardholders. However, this bulk retry affected all traders with unsettled Mastercard purchases during this 5-week window. This reprocessing may cause your bank to show a new charge on your statement while removing or adjusting the original, unsettled transaction entry.
What To Expect - Statement Adjustments: If the original charge was removed from your account or statement, it will be added back by your bank as processing completes. - Single Settled Charge: Once your bank finishes processing, you will have only one successful charge for each purchase.
Important Note: While these temporary charge removals and replacement entries may appear confusing in your feed, your final settled balance should accurately reflect your original purchase. You should not be overcharged.
Action Steps: What To Do Next Please allow a short period for your bank to complete processing and finalize your statement.
If, after your bank has completed processing, you still see duplicate charges for the same purchase: - Reach out directly to Trader Support (https://www.topstep.com/contact-support/). - Please include details regarding your affected purchase(s) and screenshots showing the duplicate charges from your banking app.
Next Steps We understand this was confusing and sincerely appreciate your patience while we worked with our payment partners to resolve the issue. If you have any remaining questions, our Support team is here to help!
Posted Aug 01, 2026 - 20:19 CDT
Identified
Overview We have identified the cause of the recent payment notifications affecting a small number of traders.
Next Steps We understand this was confusing and sincerely appreciate your patience while we worked with our payment partners to resolve the issue. If you have any remaining questions, our Support team is here to help!
Posted Aug 01, 2026 - 18:29 CDT
Investigating
Overview We are currently investigating an issue regarding duplicate payment notifications affecting a small number of traders.
Next Steps We will provide another update as soon as we receive further details. Thank you for your patience and assistance while we get this sorted out!