Topstep Status Page

This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.

We’re looking into a platform-wide issue

Incident Report for Topstep

Resolved

Live Funded Account trading is now operating normally. You can safely resume trading.

If you’re still noticing issues, please let us know by contacting our Support Team: https://www.topstep.com/contact-support/

Thanks for hanging with us. We know every second counts, and we’re glad to have you back in the markets.
Posted Dec 01, 2025 - 17:31 CST

Monitoring

We’ve rolled out a fix and systems are coming back online.

It’s safe to check your positions but would not recommend the resumption of trading, though we’re continuing to monitor closely to ensure everything stays stable.

We appreciate your patience while we got this sorted. Time to get back in the markets We’ll keep you posted if anything changes.
Posted Dec 01, 2025 - 17:27 CST

Investigating

We’re aware of an issue impacting an issue that’s currently affecting Live Funded Trader. You may not be able to open / close positions right now.

Until we resolve it, we recommend you pause trading

Our team is investigating and working to get the platform back up as quickly as possible.

Thanks for your understanding. We know time in the markets is valuable, and we’ll keep you posted.

**Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.**
Posted Dec 01, 2025 - 17:13 CST
This incident affected: TopstepX.