Topstep Status Page

This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.

We’re looking into an issue impacting some traders.

Incident Report for Topstep

Resolved

Hey Traders,

TopstepX is back online.

First, we want to apologize for the issues that have happened over the past 24 hours. We know as traders how frustrating these issues can be. We will be taking the following actions at the end of trading today:

Any negative trades made between 5:00pm CST - 5:30pm CST on 12/16 and 8:45am CST - 9:15am CST on 12/17 will be removed.
We will reopen any accounts that were closed due to a violation that occurred between 5:00pm CST - 5:30pm CST on 12/16 or 8:45am CST - 9:15am CST on 12/17

Please note we are unable to compensate for unrealized profits, missed trades or opportunities.

We understand that TopstepX is not currently living up to your (and our) expectations. We will not stop until TopstepX delivers the best Trading experience possible for our Traders.

-Team Topstep
Posted Dec 17, 2025 - 09:42 CST

Monitoring

Hey Traders,

We’ve rolled out a fix and systems should be stabilizing.

It’s safe to resume trading, though we’re continuing to monitor closely to ensure everything stays stable.

**We appreciate your patience while we got this sorted. Time to get back in the markets We’ll keep you posted if anything changes.**
__________________________________
If you’re still noticing issues, please let us know by contacting our Support Team: https://www.topstep.com/contact-support/
Posted Dec 17, 2025 - 09:33 CST

Identified

Hey Traders,

We’ve identified the cause of the issue affecting some users TopstepX.

Impact: A subset of traders may still see inability to login and connect, impacting their ability to trade

If you’re experiencing this issue, we recommend you pause trading while we work on the fix.

Our engineering team is working on a fix now to restore systems as quickly as possible.

Thanks for your understanding. We know time in the markets is valuable, and we’ll keep you posted.
__________________________________
**Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.**
Posted Dec 17, 2025 - 09:17 CST

Investigating

Hey Traders,

We’re receiving reports that some traders are running into unexpected behavior with their ability to login and connect. You may notice that you are unable to execute a trade.

If you’re experiencing this issue, we recommend you pause.

Our team is investigating and working to get the platform restored as quickly as possible.

Thanks for your understanding. We know time in the markets is valuable, and we’ll keep you posted.
__________________________________
**Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.**
Posted Dec 17, 2025 - 08:59 CST
This incident affected: TopstepX.