Topstep Status Page

This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.

We’re looking into a platform-wide issue

Incident Report for Topstep

Resolved

Everything with the new dashboard login is fully restored and operating normally. You can safely resume activity in the new dashboard.

If you’re still noticing issues, please let us know by contacting our Support Team: https://www.topstep.com/contact-support/

Thanks for hanging with us. We know every second counts.
Posted Nov 27, 2025 - 12:25 CST

Identified

We’ve identified what’s causing the issue with the new dashboard login

Impact: All traders are currently experiencing a degraded experience with the new dashboard.

While we work on a fix, we recommend you pause activity in the new dashboard.

Our engineering team is working on a fix now to restore access as quickly as possible.

Thanks for your understanding and we’ll keep you posted.

**Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.
Posted Nov 27, 2025 - 11:09 CST

Investigating

We’re aware of an issue impacting the login experience for our new dashboard. You may not be able to login right now.

Until we resolve it, we recommend you pausing activity on the new dashboard.

Our team is investigating and working to get the platform back up as quickly as possible.

Thanks for your understanding and we’ll keep you posted.

**Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.**
Posted Nov 27, 2025 - 10:41 CST
This incident affected: New Dashboard.