Topstep Status Page

This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.

We’re checking on a minor issue

Incident Report for Topstep

Resolved

Hey Traders,

The issue with TopstepX is fully resolved. Everything’s running smoothly again.

Thanks for sticking with us. We know every second counts, and we’re glad to have you back to normal.
Posted Dec 04, 2025 - 10:32 CST

Monitoring

Hey Traders,

We’ve are monitoring TopstepX and everything should be returning to normal.

We’ll keep an eye on performance to make sure it stays that way.

If you’re still noticing issues, please let us know by contacting our Support Team.

We appreciate your patience while we got this sorted. Time to get back in the markets We’ll keep you posted if anything changes.
Posted Dec 04, 2025 - 10:08 CST

Investigating

Hey Traders,

We’re looking into reports of TopstepX acting up , things like order execution not happening as expected.

Impact: Most traders are unaffected at this point but if you notice any unexpected behavior please refrain from trading while we investigate.

Our team is reviewing now to get this cleaned up.

We’re on it and will share another update soon. Thanks for hanging in there.
Posted Dec 04, 2025 - 09:42 CST
This incident affected: TopstepX.