This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.
Get email notifications whenever Topstep creates, updates or resolves an incident.
Get text message notifications whenever Topstep creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
First, we want to apologize for the issues that have happened today. We know as traders how frustrating these issues can be. We will be taking the following actions:
- Any negative trades made between 8:00am CST - 3:10pm CST will be removed. - We will reopen any accounts that were closed due to a violation that occurred between 8:00am CST - 3:10pm CST. - All trades placed in MNQH26, E7H26, and YMH26 after 1:43pm CST until 2:45pm CST will be voided.
Please note we are unable to compensate for unrealized profits, missed trades or opportunities.
We understand that TopstepX is not currently living up to your (and our) expectations. We will not stop until TopstepX delivers the best Trading experience possible for our Traders.
-Team Topstep
Posted Dec 16, 2025 - 15:40 CST
Monitoring
We’ve rolled out a fix and systems are coming back online.
It’s safe to resume trading, though we’re continuing to monitor closely to ensure everything stays stable.
We appreciate your patience while we got this sorted. Time to get back in the markets We’ll keep you posted if anything changes. __________________________________ We will be posting a message soon on how we will be making this right for traders impacted today shortly.
Posted Dec 16, 2025 - 14:52 CST
Update
We’ve rolled out a fix while traders may be able to place trades we are still experiencing issues with the DOM
We still recommend avoiding trading while we get everything back up and running fully.
We appreciate your patience while we got this sorted. Time to get back in the markets We’ll keep you posted if anything changes.
Posted Dec 16, 2025 - 13:52 CST
Identified
We’ve identified what’s causing the issue with TopstepX and the ability to execute trades.
Impact: All traders may be unable to trade or continue to see issue with the DOM.
While we work on a fix, we recommend you avoid trading at this time.
Our engineering team is working on a fix now to restore systems as quickly as possible.
Thanks for your understanding. We know time in the markets is valuable, and we’ll keep you posted. __________________________________ **Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.
Posted Dec 16, 2025 - 13:22 CST
Monitoring
We’ve rolled out a fix and monitoring ongoing issues
Until we resolve it, we recommend you avoid trading if you are able to access TopstepX
We appreciate your patience while we got this sorted.
Posted Dec 16, 2025 - 09:59 CST
Investigating
We’re aware of an issue impacting TopstepX that’s currently affecting all traders. You may not be able to Login or Trade right now.
Until we resolve it, we recommend you avoid trading if you are able to access TopstepX
Our team is investigating and working to get the platform back up as quickly as possible.
Thanks for your understanding. We know time in the markets is valuable, and we’ll keep you posted. __________________________________ **Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.**