Topstep status page

This page provides real-time updates on the status of all Topstep systems and services. If something is listed below, the team is aware and working to restore service as quickly as possible.

We’re looking into an issue impacting some traders.

Incident Report for Topstep

Resolved

Hey Traders,

The issue impacting Live account balances has been resolved and Live Funded Traders can resume trading.

If you’re still noticing issues, please let us know by contacting Trader Support: https://www.topstep.com/contact-support/

Thank you again for your patience. We know every second counts, and we’re glad to have you back in the markets.
Posted Apr 23, 2026 - 07:40 CDT

Investigating

Hey Traders,

Topstep is working on correcting an issue that is impacting account balances for our Live Market Traders. Out of an abundance of caution we are halting trading until further notice for our Live Market traders.

Our team is investigating and working to get the platform restored as quickly as possible.

Thanks for your understanding. We know time in the markets is valuable, and we’ll keep you posted.
__________________________________
**Please note: There is no need to contact our Trader Support Team, as we are fully aware of this issue and are actively working on a resolution.**
Posted Apr 22, 2026 - 11:31 CDT
This incident affected: TopstepX.