Topstep status page

This page provides real-time updates on the status of all Topstep systems and services. If something is listed below, the team is aware and working to restore service as quickly as possible.

Partial AWS Outage

Incident Report for Topstep

Resolved

This incident has been resolved.
Posted May 08, 2026 - 22:46 CDT

Monitoring

We are monitoring an ongoing AWS outage. Our services remain operational.
Posted May 07, 2026 - 22:42 CDT
This incident affected: TopstepX.