Topstep Status Page

This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.

AWS Outage

Incident Report for Topstep

Resolved

Our impacted trader services and systems have recovered from the AWS Outage.

Current Actions:
Our engineering teams will continue to monitor for stability of systems. Topstep will communicate by email the next steps to take for impacted traders.
Posted Oct 20, 2025 - 13:40 CDT

Monitoring

We are actively monitoring the AWS Outage impacting our trader services and systems.

Impact:
TopstepX: Services may be degraded during the monitoring and recovery period.
Topstep Dashboard: Operational, but Combine account creation may be degraded during the monitoring and recovery period.

Current Actions:
Our engineering teams are actively monitoring the restoration of our services to restore full capacity. We will be following up by email to impacted traders on next steps.
Posted Oct 20, 2025 - 12:59 CDT

Identified

We are currently experiencing an AWS service disruption affecting multiple systems:

Impact:
TopstepX: Users experiencing connection issues
Topstep Dashboard: Operational, but Combine account creation is significantly degraded

Current Actions:
Our engineering teams are actively monitoring the situation and working to restore full service. We will provide updates as more information becomes available.
Posted Oct 20, 2025 - 09:10 CDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:49 CDT

Investigating

We’re aware of the ongoing AWS outage and are actively monitoring its impact. Some Topstep services may be degraded or not fully functional at this time.

Our team is working to minimize disruption and will share updates as we learn more. Thank you for your patience.
Posted Oct 20, 2025 - 07:48 CDT
This incident affected: New Dashboard and TopstepX.