This page provides real-time updates on the status of all Topstep systems and services. If an issue is listed here, you can be assured that our team is working quickly to resolve it and return everything to normal.
Get email notifications whenever Topstep creates, updates or resolves an incident.
Get text message notifications whenever Topstep creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Market data from outage at market open has been restored
Posted Nov 02, 2025 - 22:21 CST
Monitoring
Trading Experience degraded. Market data from market open is in the process of being restored
Posted Nov 02, 2025 - 19:45 CST
Identified
Root cause of unavailable market data has been identified. Market data going forward is now available. Trading Experience may be degraded while engineering is working on backfilling data during the outage window.
Posted Nov 02, 2025 - 17:56 CST
Investigating
Our engineering team is investigating an incident resulting in market data not being available in TopstepX